import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*(?<!_test)\\.txt$)";
final String string = "somepath/testFile.txt\n"
+ "somepath/test_File.txt\n"
+ "somepath/testFile_test.txt\n"
+ "somepath/testFile.txtTEMP";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}