re = /^(.*(?<!_test)\.txt$)/m
str = 'somepath/testFile.txt
somepath/test_File.txt
somepath/testFile_test.txt
somepath/testFile.txtTEMP'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result