import Foundation
let pattern = #"^(.*(?<!_test)\.txt$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
somepath/testFile.txt
somepath/test_File.txt
somepath/testFile_test.txt
somepath/testFile.txtTEMP
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)