#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(((http|https):\/\/)|(www))([a-zA-Z0-9_\.\/+=!#\-~]+)(\?([a-zA-Z0-9_\.\/\?\&+=!#\-~]+))?"
Local $sString = "https://tbank.no/panel/log.php?accountID=jostein" & @CRLF & _
"http://loool.com" & @CRLF & _
"https://www.jaha.no/" & @CRLF & _
"www.jensemann.com/!#hashlink" & @CRLF & _
"www.fref.com?a=b&c=d" & @CRLF & _
"http://a.com?a=a+++b+er+fer+f!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")