package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(((http|https):\/\/)|(www))([a-zA-Z0-9_\.\/+=!#\-~]+)(\?([a-zA-Z0-9_\.\/\?\&+=!#\-~]+))?`)
var str = `https://tbank.no/panel/log.php?accountID=jostein
http://loool.com
https://www.jaha.no/
www.jensemann.com/!#hashlink
www.fref.com?a=b&c=d
http://a.com?a=a+++b+er+fer+f!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}