const regex = /(((http|https):\/\/)|(www))([a-zA-Z0-9_\.\/+=!#\-~]+)(\?([a-zA-Z0-9_\.\/\?\&+=!#\-~]+))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(((http|https):\\\/\\\/)|(www))([a-zA-Z0-9_\\.\\\/+=!#\\-~]+)(\\?([a-zA-Z0-9_\\.\\\/\\?\\&+=!#\\-~]+))?', 'g')
const str = `https://tbank.no/panel/log.php?accountID=jostein
http://loool.com
https://www.jaha.no/
www.jensemann.com/!#hashlink
www.fref.com?a=b&c=d
http://a.com?a=a+++b+er+fer+f!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}