import Foundation
let pattern = ##"(((http|https):\/\/)|(www))([a-zA-Z0-9_\.\/+=!#\-~]+)(\?([a-zA-Z0-9_\.\/\?\&+=!#\-~]+))?"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
https://tbank.no/panel/log.php?accountID=jostein
http://loool.com
https://www.jaha.no/
www.jensemann.com/!#hashlink
www.fref.com?a=b&c=d
http://a.com?a=a+++b+er+fer+f!
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)