using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(((http|https):\/\/)|(www))([a-zA-Z0-9_\.\/+=!#\-~]+)(\?([a-zA-Z0-9_\.\/\?\&+=!#\-~]+))?";
string input = @"https://tbank.no/panel/log.php?accountID=jostein
http://loool.com
https://www.jaha.no/
www.jensemann.com/!#hashlink
www.fref.com?a=b&c=d
http://a.com?a=a+++b+er+fer+f!";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}