use strict;
my $str = 'https://tbank.no/panel/log.php?accountID=jostein
http://loool.com
https://www.jaha.no/
www.jensemann.com/!#hashlink
www.fref.com?a=b&c=d
http://a.com?a=a+++b+er+fer+f!';
my $regex = qr/(((http|https):\/\/)|(www))([a-zA-Z0-9_\.\/+=!#\-~]+)(\?([a-zA-Z0-9_\.\/\?\&+=!#\-~]+))?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}