import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((http|https):\\/\\/)|(www))([a-zA-Z0-9_\\.\\/+=!#\\-~]+)(\\?([a-zA-Z0-9_\\.\\/\\?\\&+=!#\\-~]+))?";
final String string = "https://tbank.no/panel/log.php?accountID=jostein\n"
+ "http://loool.com\n"
+ "https://www.jaha.no/\n"
+ "www.jensemann.com/!#hashlink\n"
+ "www.fref.com?a=b&c=d\n"
+ "http://a.com?a=a+++b+er+fer+f!";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}