# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\{(?:[^{}]++|(?1))*})(*SKIP)(*F)|\|/\n/gm;t' <<< "help {Jason|Maria|Santa|{Lucia|Raul}'s father}|go to school
help {Jason|Maria|Santa|{Lucia|Raul}'s father}
go to school
Jason|Maria|Santa|{Lucia|Raul}'s father
Jason
Maria
Santa
{Lucia|Raul}'s father"