$re = '/(\{(?:[^{}]++|(?1))*})(*SKIP)(*F)|\|/m';
$str = 'help {Jason|Maria|Santa|{Lucia|Raul}\'s father}|go to school
help {Jason|Maria|Santa|{Lucia|Raul}\'s father}
go to school
Jason|Maria|Santa|{Lucia|Raul}\'s father
Jason
Maria
Santa
{Lucia|Raul}\'s father';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;