package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\{(?:[^{}]++|(?1))*})(*SKIP)(*F)|\|`)
var str = `help {Jason|Maria|Santa|{Lucia|Raul}'s father}|go to school
help {Jason|Maria|Santa|{Lucia|Raul}'s father}
go to school
Jason|Maria|Santa|{Lucia|Raul}'s father
Jason
Maria
Santa
{Lucia|Raul}'s father`
var substitution = "\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}