#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\{(?:[^{}]++|(?1))*})(*SKIP)(*F)|\|"
Local $sString = "help {Jason|Maria|Santa|{Lucia|Raul}'s father}|go to school" & @CRLF & _
"help {Jason|Maria|Santa|{Lucia|Raul}'s father}" & @CRLF & _
"go to school" & @CRLF & _
"" & @CRLF & _
"Jason|Maria|Santa|{Lucia|Raul}'s father" & @CRLF & _
"Jason" & @CRLF & _
"Maria" & @CRLF & _
"Santa" & @CRLF & _
"{Lucia|Raul}'s father"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)