use strict;
my $str = 'help {Jason|Maria|Santa|{Lucia|Raul}\'s father}|go to school
help {Jason|Maria|Santa|{Lucia|Raul}\'s father}
go to school
Jason|Maria|Santa|{Lucia|Raul}\'s father
Jason
Maria
Santa
{Lucia|Raul}\'s father';
my $regex = qr/(\{(?:[^{}]++|(?1))*})(*SKIP)(*F)|\|/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";