re = /(\{(?:[^{}]++|(?1))*})(*SKIP)(*F)|\|/m
str = 'help {Jason|Maria|Santa|{Lucia|Raul}\'s father}|go to school
help {Jason|Maria|Santa|{Lucia|Raul}\'s father}
go to school
Jason|Maria|Santa|{Lucia|Raul}\'s father
Jason
Maria
Santa
{Lucia|Raul}\'s father'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result