#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)IP (?:\d+|\.|[a-z]()){7}\1[^\n]+"
Local $sString = "IP bt.ru.https > 192.168.88.10.54276: tcp 3374" & @CRLF & _
"IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0" & @CRLF & _
"IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0" & @CRLF & _
"IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0" & @CRLF & _
"IP somedomain.ru.https > 192.168.88.10.54276: tcp 334" & @CRLF & _
"IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0" & @CRLF & _
"IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0" & @CRLF & _
"IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0" & @CRLF & _
"IP www.somedomain.ru.https > 192.168.88.10.54276: tcp 228"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")