const regex = /IP (?:\d+|\.|[a-z]()){7}\1[^\n]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('IP (?:\\d+|\\.|[a-z]()){7}\\1[^\\n]+', 'gm')
const str = `IP bt.ru.https > 192.168.88.10.54276: tcp 3374
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP somedomain.ru.https > 192.168.88.10.54276: tcp 334
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP www.somedomain.ru.https > 192.168.88.10.54276: tcp 228`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}