import Foundation
let pattern = #"IP (?:\d+|\.|[a-z]()){7}\1[^\n]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
IP bt.ru.https > 192.168.88.10.54276: tcp 3374
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP somedomain.ru.https > 192.168.88.10.54276: tcp 334
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP www.somedomain.ru.https > 192.168.88.10.54276: tcp 228
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)