$re = '/IP (?:\d+|\.|[a-z]()){7}\1[^\n]+/m';
$str = 'IP bt.ru.https > 192.168.88.10.54276: tcp 3374
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP somedomain.ru.https > 192.168.88.10.54276: tcp 334
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP 192.168.88.10.54276 > 192.168.88.18.https: tcp 0
IP www.somedomain.ru.https > 192.168.88.10.54276: tcp 228';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);