use strict;
my $str = '1. abcde. 2. fghijk 3. fghijk';
my $regex = qr/([2-9]\.)/mp;
my $subst = '\\n$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";