// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([2-9]\.)").unwrap();
let string = "1. abcde. 2. fghijk 3. fghijk";
let substitution = "\\n$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}