import Foundation
let pattern = #"([2-9]\.)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"1. abcde. 2. fghijk 3. fghijk"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)