$re = '/([2-9]\.)/m';
$str = '1. abcde. 2. fghijk 3. fghijk';
$subst = "\n$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;