import re
regex = re.compile(r"([2-9]\.)", flags=re.MULTILINE)
test_str = "1. abcde. 2. fghijk 3. fghijk"
subst = "\\n$1"
result = regex.sub(subst, test_str)
if result:
print(result)