const regex = /.*\'n_objects=([0-9]+)\:.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\\'n_objects=([0-9]+)\\:.*', 'gm')
const str = `{'BB912E94CDE0B0E': (None, 'n_objects=179:n-bytes-memory=0:stop-writes-count=0:set-enable-xdr=use-default:disable-eviction=true:set-delete=false;\\n')}`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);