use strict;
my $str = '{\'BB912E94CDE0B0E\': (None, \'n_objects=179:n-bytes-memory=0:stop-writes-count=0:set-enable-xdr=use-default:disable-eviction=true:set-delete=false;\\n\')}';
my $regex = qr/.*\'n_objects=([0-9]+)\:.*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";