$re = '/.*\'n_objects=([0-9]+)\:.*/m';
$str = '{\'BB912E94CDE0B0E\': (None, \'n_objects=179:n-bytes-memory=0:stop-writes-count=0:set-enable-xdr=use-default:disable-eviction=true:set-delete=false;\\n\')}';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;