import re
regex = re.compile(r".*\'n_objects=([0-9]+)\:.*", flags=re.MULTILINE)
test_str = "{'BB912E94CDE0B0E': (None, 'n_objects=179:n-bytes-memory=0:stop-writes-count=0:set-enable-xdr=use-default:disable-eviction=true:set-delete=false;\\n')}"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)