re = /.*\'n_objects=([0-9]+)\:.*/m
str = '{\'BB912E94CDE0B0E\': (None, \'n_objects=179:n-bytes-memory=0:stop-writes-count=0:set-enable-xdr=use-default:disable-eviction=true:set-delete=false;\\n\')}'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result