# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*[&?]personId=([0-9]+)/https:\/\/anotherserver.com\/dir1\/dir2\/dir3\/dir4\/dir5\/the-result?statusId=1&personId=$1/gm;t' <<< "https://server.com/de/prints/?personId=56"