import Foundation
let pattern = #".*[&?]personId=([0-9]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"https://server.com/de/prints/?personId=56"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"https://anotherserver.com/dir1/dir2/dir3/dir4/dir5/the-result?statusId=1&personId=$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)