package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*[&?]personId=([0-9]+)`)
var str = `https://server.com/de/prints/?personId=56`
var substitution = "https://anotherserver.com/dir1/dir2/dir3/dir4/dir5/the-result?statusId=1&personId=$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}