use strict;
my $str = 'https://server.com/de/prints/?personId=56';
my $regex = qr/.*[&?]personId=([0-9]+)/mp;
my $subst = 'https://anotherserver.com/dir1/dir2/dir3/dir4/dir5/the-result?statusId=1&personId=$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";