const regex = /.*[&?]personId=([0-9]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*[&?]personId=([0-9]+)', 'gm')
const str = `https://server.com/de/prints/?personId=56`;
const subst = `https://anotherserver.com/dir1/dir2/dir3/dir4/dir5/the-result?statusId=1&personId=$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);