$re = '/.*[&?]personId=([0-9]+)/m';
$str = 'https://server.com/de/prints/?personId=56';
$subst = "https://anotherserver.com/dir1/dir2/dir3/dir4/dir5/the-result?statusId=1&personId=$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;