# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(distroEnrollment Question )(\d{1,2})"
test_str = ("distroEnrollment Question 2\",\n"
"distroEnrollment Question 2\n"
"distroEnrollment Question 3\n"
"distroEnrollment Question 31")
subst = "$2 $1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.