# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\.+ )/| /gm;t' <<< "AAAAAAA ................................................. 28.02%
AAAAA-BBBBB, AB ........................................ 16.50%
AAAAAAA ................................................ 28.02%
AAAAA-BCCCC, AB ........................................ 16.50%
CCCCCCC ................................................ 28.02%
AAAAA-DDDDD, AB ........................................ 16.50%
FFFFFFF ................................................ 28.02%
AAAAA-BBBBB, AB ........................................ 16.50%"