import re
regex = re.compile(r"(\.+ )", flags=re.MULTILINE)
test_str = ("AAAAAAA ................................................. 28.02%\n"
"AAAAA-BBBBB, AB ........................................ 16.50%\n"
"AAAAAAA ................................................ 28.02%\n"
"AAAAA-BCCCC, AB ........................................ 16.50%\n"
"CCCCCCC ................................................ 28.02%\n"
"AAAAA-DDDDD, AB ........................................ 16.50%\n"
"FFFFFFF ................................................ 28.02%\n"
"AAAAA-BBBBB, AB ........................................ 16.50%")
subst = "| "
result = regex.sub(subst, test_str)
if result:
print(result)