import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\.+ )";
final String string = "AAAAAAA ................................................. 28.02%\n"
+ "AAAAA-BBBBB, AB ........................................ 16.50%\n"
+ "AAAAAAA ................................................ 28.02%\n"
+ "AAAAA-BCCCC, AB ........................................ 16.50%\n"
+ "CCCCCCC ................................................ 28.02%\n"
+ "AAAAA-DDDDD, AB ........................................ 16.50%\n"
+ "FFFFFFF ................................................ 28.02%\n"
+ "AAAAA-BBBBB, AB ........................................ 16.50%";
final String subst = "| ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}