$re = '/(\.+ )/m';
$str = 'AAAAAAA ................................................. 28.02%
AAAAA-BBBBB, AB ........................................ 16.50%
AAAAAAA ................................................ 28.02%
AAAAA-BCCCC, AB ........................................ 16.50%
CCCCCCC ................................................ 28.02%
AAAAA-DDDDD, AB ........................................ 16.50%
FFFFFFF ................................................ 28.02%
AAAAA-BBBBB, AB ........................................ 16.50%';
$subst = "| ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;