use strict;
my $str = 'AAAAAAA ................................................. 28.02%
AAAAA-BBBBB, AB ........................................ 16.50%
AAAAAAA ................................................ 28.02%
AAAAA-BCCCC, AB ........................................ 16.50%
CCCCCCC ................................................ 28.02%
AAAAA-DDDDD, AB ........................................ 16.50%
FFFFFFF ................................................ 28.02%
AAAAA-BBBBB, AB ........................................ 16.50%';
my $regex = qr/(\.+ )/mp;
my $subst = '| ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";