package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\.+ )`)
var str = `AAAAAAA ................................................. 28.02%
AAAAA-BBBBB, AB ........................................ 16.50%
AAAAAAA ................................................ 28.02%
AAAAA-BCCCC, AB ........................................ 16.50%
CCCCCCC ................................................ 28.02%
AAAAA-DDDDD, AB ........................................ 16.50%
FFFFFFF ................................................ 28.02%
AAAAA-BBBBB, AB ........................................ 16.50%`
var substitution = "| "
fmt.Println(re.ReplaceAllString(str, substitution))
}