# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!(?:<ul>)|(?:<\\/ul>)|(?:<\\/li>))([\n\r]|$)/<br>\1/gm;t' <<< "te
<ul>
<li>iasd</li>
<li>asd</li>
</ul>
ja
123"