$re = '/(?<!(?:<ul>)|(?:<\/ul>)|(?:<\/li>))([\n\r]|$)/m';
$str = 'te
<ul>
<li>iasd</li>
<li>asd</li>
</ul>
ja
123';
$subst = "<br>\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;