#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!(?:<ul>)|(?:<\/ul>)|(?:<\/li>))([\n\r]|$)"
Local $sString = "te" & @CRLF & _
"<ul>" & @CRLF & _
"<li>iasd</li>" & @CRLF & _
"<li>asd</li>" & @CRLF & _
"</ul>" & @CRLF & _
"ja" & @CRLF & _
"123"
Local $sSubst = "<br>\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)