use strict;
my $str = 'te
<ul>
<li>iasd</li>
<li>asd</li>
</ul>
ja
123';
my $regex = qr/(?<!(?:<ul>)|(?:<\/ul>)|(?:<\/li>))([\n\r]|$)/mp;
my $subst = '<br>\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";