using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!(?:<ul>)|(?:<\/ul>)|(?:<\/li>))([\n\r]|$)";
string substitution = @"<br>\1";
string input = @"te
<ul>
<li>iasd</li>
<li>asd</li>
</ul>
ja
123";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}