import re
regex = re.compile(r"(?<!(?:<ul>)|(?:<\/ul>)|(?:<\/li>))([\n\r]|$)", flags=re.MULTILINE)
test_str = ("te\n"
"<ul>\n"
"<li>iasd</li>\n"
"<li>asd</li>\n"
"</ul>\n"
"ja\n"
"123")
subst = "<br>\\1"
result = regex.sub(subst, test_str)
if result:
print(result)