using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S*)[^\[]*\[(\S*)";
string input = @"241.78.197.101 - 6734 [05/Jan/2015:16:53:26:367 -0800] ""PUT /account/transfer HTTP/1.0"" 200 427
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}